Aug 11, 2010
My Digital Life Editorial Team

Fix Windows 7 AutoPlay Dialog Box Missing or Not Appear, Display and Pop Up

When inserting a memory card (such as CompactFlash, CF-I, CF-II, Secure Digital, microSD, miniSD, Memory Stick, MS Duo, MS PRO Duo, MS Micro M2, xD, MMC and etc) into a memory card reader, or when putting in a CD, DVD or Blu-Ray disc media into a CD-ROM, DVD-ROM, CD-RW, DVD-RW or Blu-Ray optical drive, or when plugging in a USB or FireWire (IEEE 1394) removable mass storage device such as USB flash memory key drive or portable external hard disk drive, Windows 7 will always pop-up and display an AutoPlay dialog box (also known as AutoRun) that allows user to contextually select actions or actions that can be performed on the audio, video, pictures or mixed contents on the newly connected drive such as import pictures, play music media files, transfer videos, or open folder to browser files, together with some general options such as activate ReadyBoost caching to speed up computer or use the drive for backup.

Generally, Auto Play is a convenient way to directly access, execute or run many frequently and commonly used functions. However, in some cases, the AutoPlay dialog window does not appear, display, show up nor pop-up after a new drive is connected, despite the newly inserted or plugged in drive is working and can be accessed properly with a proper drive letter. In other words, the AutoPlay function stops working, or the Auto Play dialog box has gone missing, simply disappeared or gone into hiding.

To make matter worse, while the automatic AutoPlay dialog option window is not activating, the “Open AutoPlay” shell extension on right click contextual menu which associated with supported drive type to manually start AutoPlay option has vanished and missing as well.

There may be more than one causes that result in AutoPlay function no longer been used in Windows 7. In order to fix AutoPlay not working issue in Windows 7, try the following solutions or tricks in the guide below, which also points to possible error or reason to affect AutoPlay.

1. Ensure that AutoPlay is used for all media type and devices

Go to Control Panel -> Programs -> Default Programs, and select Change AutoPlay settings, or Control Panel -> Hardware and Sound -> AutoPlay.

AutoPlay Settings

Ensure that the check box for Use AutoPlay for all media and devices is ticked (enabled).

Enable and Turn On AutoPlay

Then, make sure that for the devices and media that you want AutoPlay dialog to prompt, Ask me every time is selected. If other option is selected, Windows will automatically performing the action without prompting for selection.

Alternatively, just click on Reset all defaults to reset and return AutoPlay settings to its original factory defaults.

2. Ensure that Shell Hardware Detection service is running

Type service.msc in Start Search to run Services console. Locate Shell Hardware Detection, and ensure that the “Service Status” is Running, and “Startup Type” is Automatic.

Else, start the service and change the Startup Type setting accordingly.

3. Ensure that CD-ROM AutoRun is not disabled in registry (for optical drive issue only)

For users facing AutoRun or AutoPlay doesn’t work or display when inserting a disc into optical drive, run Registry Editor (regedit), and navigate to the following registry subkey:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

Locate the AutoRun registry value in the right pane, and check that the value data for AutoRun is set as 1 (one), representing enabled. If it is 0 (zero), which mean disabled CD-ROM or DVD-ROM drive AutoRun process, re-enable the AutoRun by changing the value to 1.

4. Ensure that NoDriveTypeAutoRun and/or NoDriveAutoRun policy registry value data is correct

For most users, the main culprit of AutoPlay not functioning is NoDriveTypeAutoRun registry key, where its value has been modified unknowingly. Some third-party software program, especially disc imaging or image editing program such as Nero, PowerISO, MagicISO, and even some other application programs such as Rhapsody and VMWare virtualization products intentionally disable AutoPlay feature by changing system’s policy to avoid conflict with the program. The problem is after uninstalling the software, the AutoPlay feature does not re-enable or restore. User has to rely on trick below to re-enable the AutoPlay.

If you’re facing the drive won’t Auto Play or Auto Run issue after installing certain software, try to uninstall the software to see if it fixes the problem. Better still if it’s possible to roll back the system using System Restore to earlier Restore Point when the software is not yet installed.

NoDriveTypeAutoRun registry key is used by Group Policy to configure whether to disable the Autoplay feature on all drives of the type specified. To check this setting, run Registry Editor (regedit), and navigate to the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

or (note that above registry value, if exists, will always supersede the below user-specific key),

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Locate the NoDriveTypeAutoRun registry entry on the right pane. The registry key is in DWORD hexadecimal value, which each bit determines which type of drive to disable or enable AutoPlay feature. There are many possible value for NoDriveTypeAutoRun, some possible NoDriveTypeAutoRun registry value data includes:

  • 0×00000000 (0) enable all AutoPlay and AutoRun.
  • 0×00000080 (128) disable AutoPlay on unknown reserved file type.
  • 0×00000091 (145) default in Windows Vista and Windows 7.
  • 0×00000095 (149) default in Windows XP.
  • 0×000000B5 (181) disable AutoRun on CD-ROM drives, plus default unknown drive, removable drive (meant for floppy or ZIP), network drive and reserved drive type.
  • 0×000000FF (255) disable AutoRun/AutoPlay on all drive types.

Thus, if the NoDriveTypeAutoRun registry value data is set to 0x000000B5 (181) or 0x000000FF (255), which disables AutoRun/AutoPlay on most or all drive types, the AutoPlay won’t work when a drive is connected.

The best bet is to set NoDriveTypeAutoRun to default value as set by Windows 7 and Vista, which is 0×00000091 (hexadecimal) or 145 (decimal). Previous Windows version such as XP uses 0×00000095 (hexadecimal) or 149 (decimal). To enable AutoPlay on all drive types, set NoDriveTypeAutoRun to 0 (zero) or 0×00000080 (128) which only disable AutoPlay on unknown reserved file type.

NoDriveAutoRun registry key, which stored at the same registry location, meanwhile determine whether a particular connected drive should run AutoPlay function or not. When AutoRun is enabled on the drive, media is automatically started when it is inserted in the drive.

By default, Windows 7 and Vista does not add any NoDriveAutoRun registry subkey. And you probably don’t want to block any drive from AutoPlay too. So remove and delete all NoDriveAutoRun key in the registry.

5. Uninstall conflicting software

Some software application, especially disc image image editing program and virtual drive utilities such as Nero, PowerISO, MagicISO, Alcohol 120%, and even some other programs such as Rhapsody, MotoHelper or Motorola driver software and various VMWare virtualization products like VMWare Server and VMWare Workstation will cause conflict with AutoPlay functionality.

If you’re facing the drive won’t Auto Play or Auto Run issue after installing certain software, try to uninstall the software to see if it fixes the problem. Better still if it’s possible to roll back the system using System Restore to earlier Restore Point when the software is not yet installed.

Related Posts

  • Tired

    I’ve done all of the above and more. I still don’t see a tab for autorun in properties of CD drives nor does my iphone sync automatically with dropbox. Looks like it stopped in April and I never noticed. Am thinking it could be Kaspersky setting but can’t find one. Any new tips would be great as it looks like Autoplay is as rubbish as Peek!

  • HT

    excellent, this saved my bacon.

    small typo tho, services.msc plural you have service.msc there in your page.

  • Bob W

    Same as Cheryl except days not hours. Very impressive.

  • Cheryl

    Thanks for this solution – I have spent hours trying to work out why my autoplay was not working (and hence my phone and camera were not showing up in Picasa) all solved once I deleted that little registry key – Thanks! 🙂

  • Steve

    Thanks a lot, the registry part was the fix i was looking for.

  • John Hodges

    Brilliant you have finally fixed my no autoplay problem, I have spent two days trying all the suggestions on the web. Thanks again for the NoDriveTypeAutoRun solution.

  • Zin

    Thanks, very helpful and worked

  • Georgi

    THANK YOU WERY MUCH ! ! ! !
    I succeed to fix the problem. Now AutoPlay function works with all devices.
    Thanks again!

  • darius1364

    u r a genius
    i deleted NoDriveTypeAutoRun key

    tanks bro.

  • Melodie

    OMGosh Thank you so much, it was my registry setting in NoDriveTypeAutoRun

    Kudos for this page and thank you so much

  • mohamed iirshad

    actually i m really thanking to u cause i ve fixed my problem with this

  • Hamish

    I deleted my NoDriveTypeAutoRun before i tryed to change its value, is there anyway to get it back to change its value?

  • Johannes

    THANKS!!! I was having a bit problem on windows 7 autoplay due to the reason that shell hardware detection was disabled unknowingly. but now i just made it. thanks for your help.

  • Mario

    A thousand thanks. You guys are the only one who show me how to fixed this issue.
    I follow the instructions step by step until the NoDriveTypeAutoRun registry key did the trick.
    You are the best.
    Thanks.

  • Harry

    Thanks. That saved my day. 😀 Either Nero or some .iso image app messed with my registry.

  • Jack Hag.

    Thank you! Thank you! My AutoPlay works for CD and DVD’s again! Step 4 fixed the problem…My NoDriveTypeAutoRun registry showed 255 (decimal) value. Changed it to 145 as suggested.

  • Pingback: CD/DVD Player won't burn CDs anymore... - HEXUS Community Discussion Forums()

  • Cameo

    When we plug our Iphone 3g into the computer it always has my husbands name listed not mine or one of the kids. How do I fix this?

  • cammac44

    many thanks – have finally got CD and DVD to autoplay at last!

  • Mark Seaman

    NoDriveTypeAutoRun fix solved a real headache for me, Thanks for the info.

  • Fred

    It worked for me with the NoDriveTypeAutoRun fix .. thank you so much !!

  • guero

    thanks a lot, men u save me, thanks..

  • x

    grammatically incorrect and redundant writing. and you repeat yourself. also, you say the same thing over and over again in different words.

  • Trixah

    Thank you so much! Stupid motorola software.. I never would have thought it was that! Autoplay is back yay!

  • Pingback: Windows 7自动播放对话框丢失解决办法 | Derek's Blog()

  • danny grimes

    excuse me did you say delete no drive autorun??????as i av done?

  • Jeff

    Great!!! thank you so much. It works after restarting the computer. I set the value to 0 (step 4). Woooo Hoooo 🙂

  • Professor Martin Wei

    My flash drives lose the popup after a while. If I put in a new flash the popup shows for the new flash but not for the ones that 'lost' this ability. So I guess that it would mean I need not look for a solution in the Registry.

  • hant

    Grazieeeee !!!!!! I finally managed to restore the AutoPlay 7. You are terrific!

  • ami

    I used a program to "fix" windows problems and it disabled Autoplay. I used the REGEDIT to reset Windows 7 default in:

    HKEY_LOCAL_MACHINESoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer

    It worked!!!!

    Many Thanks!

  • Eddie Stables

    I followed your instructions, and I now get the autorun dialog box when I insert a CD.

    In Control Panel/Autoplay/Software & games, I have selected ‘Install or run program from your media’.

    When I insert an installation CD it does not install the program, all I get is the autorun dialog box with the choices of ‘Play using Windows media player’ and ‘Open folder to view files using Windows explorer’.

    Is there some way to fix this problem?

  • Ramesh

    changed the value of NoDriveTypeAutoRun frm to solved my problem.

    Thanx a lot

  • gazza1820

    Hi

    I have a internal card reader installed on windows 7 and have the same issue that autoplay won't run when i put any card into the reader. The above registry keys don't exist, should I create one? and if so, how do I do that please

  • Pingback: AutoPlay (AutoRun) Dialog Windows Open Briefly Then Auto Close » My Digital Life()

  • Happy Camper

    After a few days of trying to fix my autorun problem, I found this site.

    The option 4 solved my problem.

    Thank you so much, much appreciated.

  • trent

    Just throwing this out for anyone who's tried all these steps but still has the problem:

    Do a clean startup. Follow instructions here:
    http://support.microsoft.com/kb/331796

    After pulling my hair out for 2 days trying every method from every forum, I finally found the above link and systematically determined the problem.

    In my case, it was being caused by MotoHelper, a program that installed when I first plugged in my Droid X. If you're having this problem and you have MotoHelper on your system, try uninstalling that first. If the problem persists, try the steps in the above link.

  • Fixed webcam issue

    My Webcam wasn't getting picked up with Win 7 64bit pro.

    Used the following registry key because first one didn't exsist on my machine.

    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer

    The value was set to 149

    I changed the value to be set to 145 for windows 7, then exited out of registry.

    Plugged in my web cam and my issue was resolved.

    Thx for the fix help!!

  • Fixed webcam issue

    worked for me

  • Pingback: Restore Missing CD or DVD Drive()

  • zed

    I can't find a NoDriveTypeAutoRun in my registry

  • theo

    Just like DesiGraphr, solved my issue with NoDriveTypeAutoRun, and the culprit was indeed VMWare. Thanks!

  • willy

    try this it might help

    sfc /scannow

  • DesiGraphr

    I have faced this problem for nearly 1 year and tried all methods above except the 4th one. Finally, you save me with NoDriveTypeAutoRun.